
Forestry GIS (fGIS™) is a freeware shapefile editing program, digitizer and GIS data
query tool for Windows®. Designed for operational field managers like foresters and
wildlife biologists, fGIS has essential tools tailored for precision mapping on a desktop
computer. Use fGIS to customize layered views including aerial photos and other
imagery, draw map objects, query and search spatial data, annotate maps for printing,
and much more. The standalone program is unlimited, producing shapefiles and
geo-referenced images compatible with commercial software in an enterprise GIS
framework.

Wisconsin foresters built fGIS as a complement to enterprise data managed with more
sophisticated GIS software. Although fGIS is not meant to replace comprehensive
programs needed by GIS specialists, operational field personnel may find fGIS entirely
adequate for their needs. Many power users also appreciate fGIS for its small size,
portability to home and field computers, and innovative data tools. It is in use around
the world, with a flexible menu system that can be translated to any language.

Supported File Formats

Creates: TatukGIS Project Files (*.ttkgp)

Vector Layer Formats Supported Read Write

ESRI® SHP Yes Yes

DXF (AutoCAD® MAP) Yes Yes

DGN (Microstation®) Yes

DLG Yes Yes

MapInfo® MIF Yes Yes

SQL Coverages – TatukGIS format Yes

ESRI® e00 Yes

TIGER2000/line Yes

GML/XML Yes Yes

SDTS Yes

 

Pixel Layer Formats Supported
Write includes associated world
coordinate files.

Read Write

TIFF (uncompressed) Yes Yes

TIFF, GeoTIFF (1, 4, 8 and 24-bit,
uncompressed, packbits, group4, 
LZW)

Yes  

BMP Yes Yes

PNG Yes Yes

JPEG Yes Yes



ECW - ER Mapper® ECW Yes  

SID - Lizardtech® MrSID Yes  

BIL Yes  

ADF (ESRI® DEM Grid "Arc Data
Files")

Yes  

WMF (excluding world coordinate
file)

 Yes

IMG Yes  

JPEG2000 Yes  

SDTS Yes  
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Quick Start Guide

 

1.      When fGIS first starts, you must open an existing project file (ending in ".ttkgp")
or type in the name of a new map project. (Note: The "default.ttkgp" project
that comes with fGIS is actually a Wisconsin Transverse Mercator
shapefile with "Welcome to fGIS" as a line label positioned in northern WI. That
could cause problems if you add layers using a different projection to the default
project. Since fGIS uses the first loaded layer as the project's base coordinate
system, it is better to type in a new project name and then begin your new
project by adding a layer using the desired projection.)

2.      Next click the yellow "+" button (the Add Layer command) in the menu bar and
navigate to a folder containing map layers (geo-referenced images or vector
objects representing point locations, lines or areas). Double-click the file you
want to add to the view (or hold down the Ctrl or Shift keys to select multiple
data files to load). Loaded layers must all share a common coordinate
system if they are to line up.

3.      Double-click a layer name after it is listed in the legend to access the Properties
dialog to change the appearance features of the data.

As an example, you might want to download the fGIS State_Park.zip or 
Arborvitae.zip project to experiment with. To save download time, low resolution
imagery is provided in the zip files, 2 to 3 MB in size.



 

To digitize a new shapefile vector layer:

1.    Use Edit>New Layer (or right-click the map area and choose New Layer). Pick
either a point, line or polygon object layer to create. Keep in mind that before
you can create a new shape layer, at least one pre-existing layer (either vector
or raster data) must be added to the view. fGIS will use use the first layer to
establish a world space. 

2.    Give the new layer a name and save it.

3.    If it's not already selected, click on the New Shape Tool (pencil tool). Click points
on the map area to define the object. Be sure to digitize polygon area shapes in
a counter-clockwise direction.

4.    Right-click the map area and Stop Editing. Save the edits.

5.    In the legend (layer list), double-click the name of the new layer to access
properties controls to change how the object is displayed.

When you are done with an edit session, save the fGIS project file.

An fGIS project file keeps:

·       A table of contents of all your map layers with a record of where the data are

stored

·       Whether or not a layer was turned on (visible) when the project was last saved

·       The layer properties that you set

·       The last zoomed screen view

 Return to the Main fGIS Help Index

 

 



  

Menu Functions

Map Menu Layer Menu

Edit Menu Utilities Menu

 Map Menu: 

New Project: Navigate to the folder where you want to save the project
name. Type in a name and click "Open" to create the project. Project files for
fGIS have a ".ttkgp" file extension. (This is the same extension used by the
TatukGIS® Viewer and Editor, both of which are also built with the excellent
TatukGIS Developer Kernel. There are many differences between fGIS and the
unique TatukGIS® products. You might, however, want to look at the
TatukGIS Help PDF for additional insight into some of the common elements
such as Properties and Search functions.)

The project file stores the relative path to any data layers that are added
to the map. This can be useful if you choose to copy your project to a zip
folder or CD, enabling another user to easily open the project on their
computer if you've included the data files all in one folder or in the same



relative arrangement of folders.

The first georeferenced layer that you add to a project will establish its
base coordinate system (world space). All the layers added to an fGIS
project must be in a common coordinate system if they are to line up.

The fGIS project file saves the paths to data layers, layer display
properties, the last zoomed view, whether layers were turned on
(visible), and other project parameters.

Open Project: Navigate to an existing project file and double-click the ttkgp
file to open it. The project will resume with the last saved view. (You might
want to associate ttkgp files with fGIS so you can open them by double-clicking
through the Windows file manager. See Windows® Explorer Help if you do not
know how to associate file types with programs.)

Save Project/Save Project As: Same functions as other Windows programs.

Add/Delete Layer, All Layers On/Off, Unhide All Layers:

Layers can be added/deleted with these commands, or you can use the

 buttons on the main toolbar.

If you have a lot of layers in a project, the All Layers Off command can
be a shortcut if you want to selectively turn individual layers back on. On
older computers, the view will redraw more quickly if fewer layers are
turned on.

Unhide All Layers will redisplay loaded layers in the Table of Contents
(Legend). Use the "Hide Layer" command in the Layer Menu if layer
names are taking up too much space in a legend.

Zoom to Scale sets the screen view. The scale of a printed map is set through
the Print function on the toolbar. 

Search will highlight all of a project's vector objects that contain attribute data
that match the search criteria. Powerful Boolean search options are available.

Click the "Add Text" button to place your search criteria into the Search
Text box. In this simple example, the map will be zoomed to a Wisconsin
Public Land Survey Section located in Township 11, Range 06E, Section
24 (DTRS code 4110624). The data files for this example are available in
the State_Park.zip project example.

Spatial Selection: Instead of searching on property attributes, use the Spatial



Selection tool to choose objects from a variety of spatial parameters, including
those 

Building on the previous Search example (above), the following Spatial
Selection would zoom to all Section objects within 5,000 feet of DTRS
4110624.

Bookmarks: Save views centered on designated X/Y values and zoom level.

Layer Projection Units: The two options are Meters (UTM, WTM, etc.) and Feet

(State Planes, County Coordinate System, etc.). New projects will default to Meters. 
This setting will only affect distance and area measurements and calculations.

Scalebar Units: The choices are feet or meters, which will affect the scalebar: e.g.

 or 

Selection: Options allow a choice for color and transparency of selected
objects. The settings are saved to the project file.

Background Color: The default background is white.

R-Tree Index: The Map > Use R-Tree Index command now saves (and loads) the

Use R-Tree Index setting to the .ttkgp project file when the user saves the project. 
The Use R-Tree Index command (unnecessary for small shapefiles) is now off by
default. It can improve handling of large data layers but may cause a long pause
when the index file is first created.

New Layer: Add a new point/line/polygon vector layer (for digitizing) here or
right-click the work area and select "New Layer" from the pop-up window.

Export View will save the entire workspace view to a geo-referenced JPEG,
TIFF, BMP or PNG format image (complete with companion world coordinate
files). To save just part of a view to an image file, use the Export Image Tool in

the toolbar. Choosing the Export View to Image command opens an options
dialog. By increasing the output image size, multiple images in the view can be
put into a mosaic. Output image size can also be increased if the view is
intended for printing in a publication. Increasing the output feature size will
increase the size of labels, points, and lines in the output image.

WMF export in Map > Export View to Image dialog will create a WMF graphics at



screen resolution. The vector layers in WMF images can be resized without loss of
quality in drawing programs. WMF images are not georeferenced.

Export Legend will save the layers list (and any legend symbols you've
enabled in the Properties dialog) to an image file. Use the legend image in fGIS
maps printed with document or illustration programs.

Overview Map: This displays the Overview Map view. Using the
right-mouse-click popup menu on the Overview Map, a layer can be added and
the extent box color can be changed. The extent box can be used to change
the extent of the main map view by left-clicking and dragging in the Overview
Map view. The contents of the Overview Map are also saved to the project file.
The Overview Map can also be used in the template files (.tpl) used with the
Map > Print Map command.

Set Default Data Directory: This command will set the first directory that fGIS 
look to for data, rather than the fGIS installation directory.

 Layer Menu: 

Access Layer Properties through this menu or by double-clicking the name of
a layer in the layer list.

Zoom to Layer will fit the full extent of the selected layer to the workspace.
The other functions in this section will zoom to a shape, clear a selection or
select the last shape digitized.

Move Layer: Change the order of layers here or by dragging a layer's name
up or down in the layer list (i.e., legend or table of contents).

Hide Layer: Useful to save space in the legend (especially if you have loaded
an image catalog with many tiles). The Map Menu has an "Unhide All Layers"
command.

Use "Change Display Name" to give layers a descriptive label (rather than a
"path:\file name") in the legend/layer list. Note: You can also change a display
name by right-clicking a layer name in the map legend (when not in the Edit
mode).

"Save Layer Properties to .ini file" is used to save a set of display
parameters for a layer. A small text file ending in "ini" is added to the folder
where the layer data resides. If you add the layer in a different project, the

layer will display with the characteristic appearance defined in the ini file. (If



you change the properties of the layer for a particular project, properties will
be read from the project file rather than the ini file.) If you include the ini file
with data that you send to someone else, they will be able to open the layer

and see it with the display properties you saved.

Load .ini File: This command enables layer properties saved to an .ini file to be

used for another layer. Users could create a library of .ini files and load them as new
layers are created.

Show Shapefile Table is a database explorer/editor that shows the attributes
for all the shapefile objects in a layer. Use it to search for a particular shapefile
based on an attribute value. The tool is also extremely useful for updating or
changing attribute values as elaborated below. The window can be made

full-screen for easy editing of large tables.

To change a field value, check the Edit Table box. Navigate to the
field you want to change, and use the backspace key to delete a
value before typing in a new value. The changes are immediately
saved to the shapefile attribute table.

If the shapefile attribute table contains any of the following fields,
their values can be automatically updated with the Table/Update

Shapes Measurements Fields command:

Area Fields: Acres or Hectares

Length/Perimeter Fields: Feet, Miles, or Meters

Point Coordinate Fields: X or Y

If the shapefile attribute table does not already contain
fields with the above names, but you would like to add
the data, then follow these steps:
1. Select the Layer.

2. Start Editing (right-click the work area and choose
"Start Editing").

3. Click the Attributes Tool (the  in the toolbar).
4. Click on the shape with the Attributes Tool. The
attribute table (data dictionary) opens.

5. Right-click the UID column. Choose "Add Field". Type
in ACRES, HECTARES, FEET, MILES, METERS, or (for
points objects only) X or Y as the field name and
designate the field as a number.



6. Stop editing and save changes.
Next, click "Show Shapefile Table" either from the Layers
menu or by right-clicking the layer name. Initially, the
new ACRES, HECTARES, FEET, MILES, METERS, X or Y
columns are empty. Click Selection/Select All. Click
Table/Update Shapes Measurements Fields. The 
new field values will then be filled in!

Use the "Populate" button to change the contents of Text Fields with
whatever text you type into the Search/Populate text box. In the
example above, all the Layer values have been renamed
"PLSS_Section".

Using the Selection > Copy Selection to Clipboard command on the 
Shapefile Table dialog will copy the selected records to the clipboard in
tab delimited format. This format can be pasted into Excel.

The Filter checkbox on the Shapefile Table dialog will filter the table for
the value in the input box for the selected field. For example, to locate
all records with an ACRES value of 640, type 640 in the Search field,
then Search with Filter enabled.

The filtered records can be highlighted (selected) on the map with the
Selection/Update Selection to Shapefile menu command. This can be 
very useful in tandem with the main menu's Layer/Export Layer
command (below).

The number of selected records and the record total are displayed on
the Shapefile Table dialog (not available if Field/Sort commands are in
use).

Additional information about this tool can be found or by clicking the Help
button in the tool's menu bar.

Image Transparent Zones: Users can set the borders of digital orthophotos and

the backgrounds of DRGs to transparent using the Image Transparent Zones dialog. 

The "Export Layer" function can clip out a part of a vector file. The portion
saved can be selected by a number of parameters, including a designated
extent or filter based on a query statement. The exported layer will be saved

as a shapefile. The Layer > Export Layer command uses the selected layer in the

legend.



 Edit Menu: 

If accessed from the menu bar, the Edit Menu has the appearance shown
above-left (some choices will be gray and unavailable, depending on what you
are doing). You can also access the Edit Menu by right-clicking the work area.
If you do, an Edit Menu like the one above-right will appear at your cursor.
Note that the fGIS status bar turns red when the program is in the edit mode.

Start/Stop Editing: When you start editing, choose the appropriate digitizer

or editing tool from the tool bar. 

If you are digitizing a complex object, but the control point jumps away
from the leading position, undo the last action to remove the error and
then hold down the shift key before clicking the correct leading 
position. Always try to digitize polygons in a counter-clockwise 
fashion, so as to give the polygon's vertices a clockwise winding.
This is essential for the Splitter Tool and other polygon editing
functions to work properly. Use Polygon Functions>Fix Polygon
Winding if needed to give vertices a clockwise winding.

You can modify an object's data attributes table only when you are in the

edit mode. Hit the object with the Attributes Tool  to open its data

table. Right-click the left column to make changes or add field names.
Double-click the right column to adjust field values.

You must click "Stop Editing" and save your work before you can
switch layers or make property changes in the legend/layer list.

Close Shape: Sometimes a polygon shape is left "open-ended" when using the Edit
Points tool OR sometimes the user doesn't want to double-click a final point when
using the New Shape tool. The Close Shape command closes the polygon shape and
enables the Attributes tool.



Undo/Redo: Same functions as other Windows programs.

New Shape: Selects the digitizer tool and readies fGIS to create another shapefile
object.

Delete Shape: Works only with selected objects in the active layer.

Save Edits/Abort Edits: Same functions as other Windows programs.

Polygon Functions: (For details, see the Polygon Editing Tutorial.)

1. Subtract Polygon: The geometries of all polygons that overlap 
the selected polygon will be subtracted from the selected
polygon.  This makes it possible to append polygons to existing
polygons or fill in holes between polygons.

2. Fix Polygon Winding: Clockwise wound polygons work best 
with Split Shape Tool, Append Polygon Tool, and Subtract Polygon
command. Use Fix Polygon Winding to give vertices the correct
order.

4. Drill Polygon: The geometry of the selected polygon will be 
subtracted from the geometry of any polygons that it overlaps. In
this manner you can cookie-cutter-in new polygons.

5. Delete Part: Individual parts of multi-part polygons can be 
deleted.

Note: Subtract Polygon and Drill Polygon
commands only work with shapes that are selected
with the Pick tool. 

Union Selected Shapes: Merge multiple objects in the active layer while in the 

Edit mode. Use the Pick Tool  and Ctrl key to select multiple objects. This
command works for lines and polygons.

Select Last Shape: Useful for selecting a shapefile just created, either to drill,
subtract (polygons) or delete the object.

Copy or Paste Selected Shape: Shapes can be copied from other layers to 
the layer being edited. Line objects can only be pasted into line layers, polygon
objects into area layers, etc. The shape is copied in WKT (Well-Known Text)
format so that users could create or edit a shape in a text editor and paste it

directly into the layer. To see the format, copy the shape and paste into a text
editor.

Set Snap Distance: The system default distance is 15 pixels. Values greater than
35 are not recommended. (Select the layer to snap to on the fGIS toolbar.)

WTM Location to Lat/Lon: Copies the lat/lon of the position clicked to the 
Windows clipboard. This tool works only with Wisconsin Transverse Mercator
data sets.

 Utility Menu: 



"Load Library Layer" simplifies selecting GIS layers. If you have a large
collection of  enterprise GIS data, the naming conventions often result in
cryptic files names. What's more, the layers might be stored in many folders
(which also have code names). You can solve the problem of remembering
what's where by creating a DBF file with a common alias for each layer and a
path to each file. Once you create such a table, just use Load Library Layer and
click a shape layer in the table. fGIS will add the layer to your map's table of
contents. 

Here's an example of a DBF file containing paths and plain language file
names:

You can use Load Library Layer/Add Env Variable to set a path to each

folder, or you can use Notepad to do the same by creating a file named
"env.txt" in your fGIS program folder. Here's a sample environment text
file for the first two folders shown above:



In this example, the shapefiles can be found on the user's E:\ drive in the
path as shown. Once the Library Layer file is set up, just click once on the
layer you want, and fGIS will load it.

Users can also to select a different env.txt file instead of the one in the /fgis
directory by using the Env > Set Env File command on the Load Library Layer
dialog. The default env.txt file can also be set in the language.ini file.

The Load Library Layer dialog can optionally load an .ini file specified in the
INI_FILE field of the Layer Table. This field can use environment variables for
the path.
 

When a new Env file is selected with the Env > Set Env File command and the
project is saved, the new Env file name will be saved to a file named fgis.ini
and used as the default Env file.

In the Load Library Layer dialog, layer display names can be specified in a
field named "Alias" in the layer table, however the names stored in a .ini file
will take precedence.

 

WISCONSIN FORESTERS NOTE: The fGIS distribution zip
archive includes an "env.txt" file and a "layrdata.dbf" file,
which are based on the layout of the Wisconsin DNR dvgislib 

data store. The env.txt file assumes that your Wisconsin DNR
GIS data is on your local computer in the following path:
"C:\GIS_DATA\dvgislib\wi_tile\". If your data is in a
different path (such as a Regional tile), you can edit the
env.txt file (use search and replace in Word) to reflect the path
you use. Do not use spaces or the dash (-) character in folder
or file names! If you open layrdata.dbf with Load Library
Layer/File/Open command and the shapefile is present, then it 
will load in fGIS when you click its row in the data table.

Keep in mind that the Wisconsin Regional library tiles do not
contain all the layers present in the full Wisconsin tile library
directory. If a layer is not present on your local drive, you will
get the following message:

The Shapefile Projection Utility converts shapefiles between Geographic 

(lat/lon), UTM NAD83 and WTM NAD83 coordinate systems. In the following
example, a Geographic Census TIGER shapefile is converted to a UTM Zone 15
file:



Be sure to organize your shapefiles into folders with logical names. If a
source file has a coded name, you might want to change it to plain
language as shown in the Output Shapefile above. (Avoid the use of "-"
or other non-standard characters in file names and directory names.)

Wisconsin UTM zones numbers are here. Worldwide UTM zones are
included in the fGIS Shapefile Projection Utility.

The Convert Utility interprets unit measurements, translating a value from
one unit to any other. Selecting the Convert Utility starts Josh Madison's
Convert program (more information about Convert can be found in the

convert_readme.txt file in the fGIS system folder). Exit the Edit mode 
before using Convert.

Typically, you'll use convert by (1.) copying a value from an attribute
table (click a cell to make it active, then right-click the value and copy).
In Convert, (2.) drop the value to be translated into the Input box and
read the converted value in the Output box. Use the tabs in Convert to
choose the input and output units. The two steps are shown below using
a square meter area value from a Wisconsin DNR PLSS section attribute
table, changing it to acres.



The Join dBase Table to Shapefile Utility can join a dBase table to a 
shapefile's attribute table based upon a common field from each. The common
field names do not need to be identical. The common fields should, however,

contain the same type of data. 

The join is performed in a one-to-one relationship manner only. Only the first
record from the input dBase table in a one-to-many relationship will be joined
in the output shapefile.

The join process may take several minutes for very large shapefiles and dBase
tables.

Note: Microsoft® Excel tables can be easily exported as dBase files for use in
fGIS.

Join Access Table to Shapefile: The Join is a "live" join to the database. The
joined fields are visible in the Layer Properties, Attributes Tool, and Search dialogs.

The Sort Shapefile function can improve the quality of an Access table

join: 

This function will sort the selected shapefile by the selected attribute field and
output it to a new shapefile. The new, sorted shapefile should be added to the
theme (legend or table of contents) in order to take advantage of it for the Access
table join in (b).

a.



Access table records are now sorted by the join field prior to creating the join.  The
join works best if there is a one-to-one relationship between the records in the
shapefile and the Access table, AND if the records in each dataset are sorted by the
same field.

b.

An Access table join (created via the Utilities > Join Access Table to Shapefile
dialog) can be saved to and reloaded from the project file.

Diagram Designer: Diagram Designer is the print layout module/technical
illustration program. Access it either through the Utility Menu or through the
prompt when using the Export Image Tool. Detailed instructions about using
Diagram Designer are here.

Lat./Lon. Location to WTM: The Lat/Lon Location to WTM utility is a "Go To" 

utility that works with WTM, UTM or WGS84 data. If requisite shapefile layers are
loaded, it can also serve as a Public Land Survey System locator.

This Public Land Survey System section finder is specific to users with data that
contain a DTRS* or DTRSQQ attribute field. Type in the lat/lon of a location
and click GO to zoom to that PLSS section. A large red dot is placed at the
designated coordinates. The layer containing the DTRS reference data must be
specified. The Section, Town and Range information for the lat/lon coordinates
are copied to the Windows clipboard.

This tool works with either UTM zones or WTM (Wisconsin Transverse Mercator)
data. UTM users can modify the language.ini to display "UTM" text instead of WTM
and place their UTM zone at the top of the projection list. For example, if your data
is in UTM zone 16, add the following line to the [frmLatLongToWTM] section of the
language.ini: 

frmLatLongToWTM.lbxProjections.Items[0]=UTM,16

 

The dialog checkboxes by Latitude and Longitude add "-" signs to the input
coordinates to designate locations in the southern or western hemispheres.

The WTM location to Lat./Lon. command (from the view's right-mouse-click popup
menu) will also utilize whatever projection is selected in the Lat./Lon. to WTM form
(WTM or any UTM zone). Again, UTM users can modify the language.ini to display
"UTM" text instead of WTM, or to place their UTM zone at the top of the projection
list.
 

*The DTRS code is a seven-digit number that uniquely identifies all PLSS
sections in Wisconsin. A ‘2’ in the first digit indicates a range direction of West.
A ‘4’ in the first digit indicates a range direction of East. The second and third
digits contain the township number (0 through 53). The fourth and fifth digits
contain the range number (01 through 20 West, 01 through 30 East). Digits six
and seven contain the section number (01 through 36). See the

"Section_lines" shape (actually a polygon layer) in the State_Park.zip example.
 



Import XY Text Table to Shapefile: This command will create a point shapefile
from a comma delimited or tab delimited text table with XY coordinates in decimal
degree format.

The text file should be laid out in the following order: ID, X (longitude), Y
(latitude), Text. The first row of the table should contain field names
(which can be substituted for the "ID, X, Y, Text" variables). Text
containing spaces should be enclosed in double-quotes. See an example
text file here.

Click "Import" to create the point shapefile. The Import XY Table to

Shapefile dialog adds the new shapefile to the view after creating it.

Additional data values can be added to the new shapefile's attributes with
the Join DBF or Join Access Table Tools above.

Hint: If you use a simple program like Waypoint+ to 
download waypoints from a Garmin GPS receiver and
save them as comma-delimited text, the "Import XY 
Text Table to Shapefile" utility in fGIS can create a GPS
waypoints shapefile layer. You may need to project the 
GPS lat/lon coordinate shapefile to UTM or WTM to align 
with your other layers.

 The Image Catalog Utility dialog (Utilities > Image Catalog Utility) will load
all layers in an image catalog and optionally hide them all upon loading. The
DNR uses image catalogs to load groups of DRGs. There are also commands to
Turn On/Off & Hide/Unhide all image layers as a group.

See instructions for the 3D Viewing Utilities here.

Hyperlink Utility: This tool changes the function of the Pick tool to display the
file specified by the filename in the Hyperlink field for the shape selected.
Images, text documents, web pages, etc. can be used.

Search for Township/Range/Section: This tool requires that an appropriate
Public Land Survey System layer with a DTRS attribute is loaded.

Utilities > Routing Utility: The Routing Utility will locate addresses (using the
From text and the Find Address button) and find the best route between two
addresses (using the Find Route button) in the Routing Layer. The Routing Layer is
typically a Road shapefile based upon the US TIGER roads data. Such a layer is
available in the State_Park.zip fGIS sample dataset and for WI from the DNR. See
dialog for more help. (Attribute names shown in light gray text in the dialog
window, set for US TIGER Census road layers, may also be edited.)

Utilities > Live GPS Utility [BETA]: This utility will display the GPS location for a
GPS receiver outputting NMEA format data connected to the COM port. The location
can optionally be snapped to a line layer to correct for moving features. This utility 
has not been tested with moving GPS receivers. See the dialog for more help.

Utilities > Clip Shapefiles: Use this dialog to clip line or polygon layers to the



boundaries of a polygon layer. Point layers can NOT be clipped using this dialog. To
clip out point layers, select the points using the Map > Spatial Selection dialog, then
create a new shapefile of the selected points using the Layer > Export Layer dialog.

Utilities > Merge Shapefiles: This dialog can be used to merge multiple shapefiles
into a new one. All fields from all input layers will be included in the output
shapefile.

Utilities > Buffer: Select a point, line or area object and create an area shapefile
file around it at a designated radius or width. The following example creates a
one-mile circular buffer around the point "WRPQ-AM":

The Buffer utility can also be used to create buffers around multiple selected
objects or all the objects in a layer. The buffered area will initially be
displayed with solid gray fill, which can be changed through the Properties
dialog.

New Shapefile Field Manager dialog to retrieve default attribute table settings.
These settings are stored in a file named fgis.ini that is stored in the same directory
as fGIS.exe. The New Shapefile Field Manager dialog can also be accessed from the
Utilities > New Shapefile Field Manager command. An example fGIS.ini file to
be used with the New Shapefile Field Manager is included (open it in Notepad or
other text editor).

Utilities > Repath Project File: This dialog is useful for modifying a project file
after data, projects, or directories have been moved.



Utilities > Generate Cruise Points: Select an area object and fill it with either
random or systematic points. The generated points are saved as a shapefile, which
can be used in fGIS or transferred to a GPS unit for navigation. Other GPS software
such as DNR Garmin Tool or OziExplorer would be needed to upload the points to a
GPS receiver.

Random Grid Points Systematic Grid Points

 
 

 

 Help Menu:



F1 will take you to the Help Index.

About fGIS shows basic copyright information. The file "license.txt" in the fGIS
program folder provides additional details.

 



  

Tools 

Save 

Saves the current project and view. To save the project with a different name
(leaving the original intact), use "Save As" from the Map Menu.

Print Simple Map 

After clicking Print/OK, fGIS will prompt you for a map title, subtitle and footer to
print on the page. You can also specify the scale at which to print and select the
fonts used in the map titles and footer. If you wish to print at a scale of eight
inches per mile, designate a scale of 1:7920. A print preview is provided.

Hint: Prior to using "Print Simple Map", use the Center Tool to choose a specific

point for the map center. That way, if you make subsequent map adjustments, you
can repeat the print job with similar boundaries.

Note: Some printer drivers have been found to misalign image and vector layers
when map titles/footers are included in a simple print job. If that happens, leave
the fields blank.

 



fGIS offers three additional print options:

The Send Map to Word command (available through the Map>Print
sub-menu) will send an image of the view at a user specified resolution and
scale to Microsoft® Word. The user is given options to add the map to an
existing document (browse to the document) or to create a new document. A
Wisconsin DNR MFL Map Header document file is included in the fGIS folder to
use if needed. The "Crop" image tool in Word creates a mask around the image
without changing the scale or distorting the image.  The "Crop" tool is available
on the Picture toolbar in Word. (Use View>Toolbars in Word to turn on the
Picture toolbar. Apply the Crop tool to the handles in the middle of the picture
edges for best results. You might need to move the image back and forth to
access the edges.) Also, fGIS adds the map scale (e.g. 1:7920) as text in Word
for the user's reference. The Send Map to Word command has been tested on 
Word 97, 2002 and 2003 with satisfactory results.

A new dialog includes the previous Simple Map as well as a Template Map
printing section, page orientation, and printer setup functions. A template

example is included (print.tpl) for advanced users who want to design their
own. The template files can be edited in Notepad. (Wisconsin DNR foresters
will receive additional print template files from the GIS specialist.)

A fourth option through the Export Image tool will send the map to a 
technical illustration/page layout module called Diagram Designer. You
can add headers, legends, annotations and non-spatial symbols from

template palettes in the Diagram Designer module. 

Layer Add/Delete 

Add or delete layers to the table of contents with these buttons. When you
click the Add Layer button (+), a file browser opens. Navigate to to the folder

where the data files are located. fGIS will list the files it is capable of
opening. You can select more than on file at a time by holding down the Shift
or Ctrl keys when you click on file names. The Delete Layer button (-) drops
the layer from the table of contents (but does not change the files located on
your hard drive).

The Add/Delete Layer functions do not work if you are in the Edit mode.
(Stop editing first.)

Zoom and Position  

fGIS provides a number of tools to change the view.

The first, with a globe, will zoom to the full extent of all loaded layers. (If you
want to zoom to the extent of a particular layer, use "Layer/Zoom to Layer"
from the menu bar.

The next two (- and +) zoom out or in with incremental steps.

The open magnifier is a freeform zoom. Drag a box down and right to zoom in.
Drag a box up and left to zoom out.

The Pan Tool (hand) is used to drag the view to a new position with the
mouse.

The circle tool will re-center the view on any point that you left-click.

The Prior Extent  tool will take you back to a previous view. Only the 
previous 10 extents are available. The Prior Extent history is created by the Zoom,
Pan and Re-center tools (not from the bottom or right-side slider controls).



Attribute 

The Attribute Tool will display the attribute information (data dictionary) of any
object you click in the view. The object will first flash red and yellow, then an
attribute table will open. If the object is in the active layer, and if the Edit mode is
on, the attribates for the selected object may be changed.

Note: If you are using the Attribute Tool, but are
unable to "hit" the object you want, move the target 
layer containing the object to a higher position in the
layers list. Each area layer is somewhat like a pane of
glass. You can't hit an object in a lower pane if an
object in a higher pane is in the way.

If you are in the Edit mode (right-click the view and click "Start Editing"), you

can use the Attribute Tool to change the data values associated with an
object. After clicking on an object, a table with two columns similar to the
following (with a data dictionary specific to the object) will open:

Right-click in the left column to change a field label or to add/delete a field.
You can also add a new field by right-clicking below the last row. Left-click in
the right column change an attribute value. Click OK when finished to save

your changes.

Pick 

The Pick Tool allows users to select shapes from the active layer in the
legend. Selected shapes are highlighted in red. Multiple shapes can be
selected by holding down the CTRL key. Selected shapes can be merged with
the Union Selected Shapes command in the Edit menu. 

 Measure 

Click points to forma a line or shape. Double-click to view the measurements.
Measurements are reported in acres, feet, chains (1 chain = 66 feet) and statute
miles.



Note: fGIS will produce measurements only for data that is
meter-based or feet-based. If you use data with Geographic 
coordinates (lat/lon coordinates, which are decimal-degree

based), fGIS will not generate areas or distances with the
measure tool or other shapefile creation or editing functions.

Export Image 

Drag a bounding box to export a geo-referenced image of any portion of the
screen view. The Export Image Tool can be used, for example, to clip out an image
of just one survey section.

After dragging the bounding box, the following resolution output dialog will open.

The default resolution of 1 will save the image at the screen resolution (which
might result in a coarse picture when printed). Increasing the resolution will result
in a larger file that may print better, depending on the results you are seeking. (A
resolution of 2 is usually optimal for Wisconsin MFL maps, provided you zoom in to
fill the view with the PLSS section first.)

Images can be saved in TIF, PNG, BMP and JPG formats (with the associated world
coordinate files). The PNG format is especially useful for maps that do not include
raster images like aerial photos, keeping the file size relatively small.

When you use the Export Image Tool, an option will appear to open the
image in Diagram Designer, a page layout module. You can learn more 
about using Diagram Designer here. [Note: If an image fails to open in
Diagram Designer on the first try, repeat the image export a second time using
the same file name as in the first go. The image will open in Diagram Designer on
the second try. This is a known bug in fGIS, which will be corrected. Also,
exported images must be saved in a PNG, BMP or JPG format if they are to be
used in the Diagram Designer module.]

Split Shape 

The Split Shape Tool (a tomahawk symbol) divides a polygon or a line into

smaller units by drawing a line through it. The Split Shapes Tool updates the area
and perimeter/length of each subunit when a polygon or line is divided.



Splitting a Polygon with a Line

(Double-click to complete the procedure.)

One of the easiest methods to digitize forest cover types (or any other land cover

polygons) is to first outline an entire parcel, and then use the splitter tool to
subdivide the whole into its parts.

Occasionally, you might encounter a polygon that displays a warning that the
shape cannot be split when you try to subdivide it. That is caused by some
irregularity in the structure of the object's data. If that happens, use the Edit
Points Tool to slightly adjust the object, and then try the Split Shapes Tool again.

Warning! A precaution to keep in mind with the Split
Shapes Tool: Do not try to follow the boundary of a
shape. Since the Split Shapes Tool does not snap to
other objects, trying to follow another boundary will 
result in "orphans" (polygon slivers that you'll need to
delete and clean up later). Plan your technique so as to
cleanly divide polygons, using more than one split if
needed.

Hint: The line object splitter function is useful for cleaning up GPS tracks
imported through the DNR Garmin Tool or other GPS programs. It can be 
used to snip out extraneous GPS track segments.

Edit Points/Select Tool 

Select the layer containing objects that you want to edit, then right click the view
and choose "Start Editing". Click the Edit Points Tool, and then left-click the object
you want to change (or select). Click near the center of the object to avoid changing
a vertex on the first click. Move nodes or insert vertices with the Edit Points Tool.

You can also use the Edit Points/Select Tool to delete a shape by first selecting it
and then hitting "delete" on your keyboard.

Additional Polygon Functions that can be used with the Edit Points/Select Tool are
listed below.

Note: It's often easiest to digitize a complex shape by
first enclosing it in a simple polygon. Then, use the Edit
Points Tool to pull the shape to conform with the object
being digitized.

New Shape 

When you are in the Edit mode, click the New Shape Tool to insert another object in 
the active layer. To create a new shape layer, right-click the view and select the
appropriate shape category from the menu that opens:



You'll be given options to add feet, acres, meters and hectares to the shape's
attribute table.

Notice that the Edit Menu includes a Polygon Functions option:

(Note: See the Polygon Editing Tutorial.)

These tools make it possible to digitize complex shapes in fGIS without
producing "orphans" or voids between shapes. See the following examples
(view sequence left to right):



The "Fix Polygon Winding" command is used to reorder the vertices of a
polygon in a clockwise order. As a routine, you should generally draw polygons
in a counter-clockwise direction (which causes the vertices to be numbered
clockwise). When vertices are numbered clockwise, the polygon can be split or
manipulated in many ways. If you forget, however, and need to fix the
winding of the vertices, use the "Fix Polygon Winding" tool.

The "Delete Part" removes the selected polygon.

The "Add Part (or make hole)" tool is used to make islands, lakes and other
donut holes within shapes. To make a hole, first choose to make a New Shape,
then click "Polygon Functions>Add Part". You will immediately see the hole 
in an underlying polygon if you digitize in a clockwise direction
(opposite the normal procedure, making the vertices wound [numbered]

counter-clockwise). To fill the hole with a lake, the lake should be created in a
separate layer by snapping to the edges of the hole.

Note the significant difference between using Add Part and
the Drill or Subtract functions. With Add Part, the user must 
click that command first and then digitize the hole. If
digitized clockwise, the hole appears immediately. If
digitized counter-clockwise (the "normal" direction under

other circumstances) clicking "Fix Polygon Winding" will
make the hole appear.

With the other Polygon Functions, the user first digitizes the
new overlapping polygon, then clicks a command to drill or
subtract.

 

 

Traverse Tool 

Use the Traverse Tool  to specify the direction and distance of the next vertex in a
line or polygon. Designate the direction in azimuth degrees or
degrees-minutes-seconds, then enter the distance to the point in feet or meters.
In some instances, you may need to move the Add Traverse Points dialog box so it
doesn't block the view of the new point you want to add. The Traverse Tool in fGIS
can plot most simple property deeds or layout a precise cruise course (which you
could transfer to a Garmin GPS unit with the DNR Garmin Tool).



 

NOTE: Polygon areas in fGIS are calculated with math
functions, but screen resolution and zoom scale will have an
effect on the precision of vertex coordinates. The higher the

screen resolution (1024x768 is better than 800x600) and 
the larger the scale (the further in you've zoomed), the
more precise the coordinates of vertex points that the user
creates will be (and the more accurate the area
measurement generated by fGIS). 

Undo/Redo 

Click undo to remove an incorrect vertex or to restore a deleted point when
making or editing a shape. The Undo/Redo Tools do not work with any other
function.

Snap

When digitizing a shape, you can enable snap to objects in any vector layer by
selecting the appropriate layer in the drop-down list. The vector layer names used
in the map legend will be displayed as in this example:

The snap layer can be changed at any time. For example, you might start by
snapping to a road layer, then snap to a stream when the object you are digitizing
approaches objects in the hydro layer. Note: fGIS only snaps to object vertices.

 



 

  

Layer Properties

The Properties menu in fGIS is accessed by double-clicking a layer name in the
map legend/table of contents. (Note: You must exit the Edit mode before you can
access the Properties dialog for a layer.)

fGIS and the freeware TatukGIS Viewer (both built with the TatukGIS DK) share
similar property adjustment features. You are encouraged to read the TatukGIS 
Viewer Help PDF for additional information and examples about map properties.
You might even want to experiment with fGIS project files in the TatukGIS
Viewer, which offers a few different features. You can download a free copy of the 
viewer here.

The fGIS vector layer tabs offer extensive possibilities for adjusting the
display of vector data. Following are basic purposes of each tab:

The first option you are likely
to need from the Layer tab is
Transparency. If you are 
adjusting the properties of an 
area object, reduce the

transparency if you want to 
see through the object to
layers below. You can also set 
the Area Fill Pattern (below)
to transparent if you want the 
object's outline to show with 
no internal fill.

Minimum/Maximum scale
sets the zoom levels at which 
layers display. The visibility
checkbox lets you turn off a 
layer without deleting the
layer from the table of 
contents.

In this example, layer objects 
will become visible when the
scale is 1:15840 or larger 
and the area of the object is
greater than 5 acres.

The Render tab is used for
creating thematic maps 
(different colors, line width,



labels, area fills, etc.) based 
on values of data associated
with vector objects. See the
TatukGIS Viewer Help PDF for
details.

The center tab will be named
"Area" for area objects, 
"Line" for line objects, or
"Marker" for point objects. 
The sub-option tabs are used
to set the basic color, line 
width, symbol or fill of a 
vector object.

If you wish to see through 
an area object, set the 
pattern to transparent.
You can also set partial 
transparency through the
Layer tab.

Click the lower check box for
the object's theme to appear 
in the map legend under the
layer name.

There are a couple ways to 
add symbols to your maps.

One is to create a point layer,
locate points on the map, and 
then designate a symbol font
or bitmap for the points 
through the fGIS Properties 
menu (left). 

The other is to export an
image of your fGIS map to a 
document, paint or 
illustration program where
you can also add legends and 
annotations. (The draw
function in Microsoft Word®
is useful for annotating maps.
Zoner Draw 3 and AutoRealm



are a couple free drawing
programs to consider.)

The Label tab offers many
options for the appearance 
and location of text labels.
Select a field (taken from an 
objects attributes table) to
use for a label from the 

drop-down box. 

Labels can have more than
attribute listed and be more 
than one row high. The
following text string in 
"Field", for example, will list

the Stand Number, Primary 
Timber Type, and (on row 2) 
the Secondary Timber Type:

:#<:STAND>, 

<:PRIM_TYPE>\n<:SEC_TYPE>

The text inside the brackets
(e.g., <:STAND>) are 
attribute names from the
object's data dictionary.

See the TatukGIS Viewer 
Help PDF for additional
details.

The Chart tab can be used to
create a pie or bar chart 
symbols based on an object's
attributes. See the TatukGIS 
Viewer Help PDF for details
(about 1.4 MB ― requires a
live Internet connection).

The Properties menu for raster layers has two tabs: . 

If you have two raster images that you'd like to blend, for example,



load them both as layers in fGIS and set the top image transparency,
contrast, etc. with the Properties tool. Here's an example of a
grayscale aerial photo on the left, blended with a color elevation map
(from 3DEM, with red/orange being the highest elevations) on the
right. This combination was achieved with the raster layer/pixel
settings shown below.

As with the Layer tab 
for vector objects, you
can set the 

minimum/maximum 
scale at which an 
object will be
displayed. You'll need 
to experiment with
the Transparency and 
Addition values to get 
the best appearance.

The Pixel tab provides 
more raster
adjustments as 
shown, allowing fine 

adjustment of raster 
images.

Comments can be added to the Layer Properties dialog and saved with the
project or to the layer.ini file. (Layer Properties dialog > Layer tab > Info
section).

For additional examples of layer.ini files, see the "ini" directory in the fGIS
program folder. It includes "ini" properties for use in Wisconsin DNR Managed
Forest Law (MFL) maps. Standard point, line and polygon display properties used
for MFL maps can be loaded by making a layer active and using the function
"Layer=>Load .ini".



 



 

fGIS Polygon Editing Tutorial
(Updated for 2005.01.12 build of fGIS)

 

Index:

 

A.  Splitting Polygons using the Split Shape Tool

 

B.  Appending Polygons using the Subtract Polygon Command

 

C.  Creating Holes in Polygons and Removing Holes from Polygons

 

D.  Drilling Polygons using the Drill Polygon Command

 

E.   Creating Polygons that are Within other Polygons

 

 

A.  Splitting Polygons using the Split Shape Tool

 

The Split Shape Tool ( ) is used to split existing polygons into smaller polygons. 

 

In the following example, the green polygon labeled "PR" (show below) will be split into

two polygons using the Split Shape Tool.

 

The green polygon labeled "PR" will be split using the Split Shape Tool.

 

1.  Select the Edit - Start Editing command to edit the polygon shapefile.

2.  Click on the Split Shape Tool ( ).



3.  Digitize a split line that begins and ends outside of the polygon to be split, as shown

below.

 

To split a polygon, the split line must begin and end outside of the polygon.

 

4.  Double-click to end the split line and split the polygon into two polygons.

5. The result of splitting the polygon with the Split Shape Tool is shown below.  Notice

how the attributes of the original polygon have been copied to the newly created 

polygons and that the label is automatically updated.

 

The results of splitting a polygon using the Split Shape Tool.

 

 

B.  Appending Polygons using the Subtract Polygon Command



 

When digitizing polygons that are adjacent to one another, it is often easier to append a

new polygon using the Subtract Polygon command, rather than trying to snap the new

vertices to the vertices of an existing polygon.

 

In the following example, the red polygon labeled "A" (shown below) will be appended to

the adjacent polygons using the Subtract Polygon command.

 

The red polygon labeled "A" will be appended using the Subtract Polygon

command.

 

1.  Select the Edit - Start Editing command to edit the polygon shapefile.

2.  Using the New Shape Tool ( ), digitize a new polygon that overlaps the edges of 

the green and blue polygons as shown below.



 

The overlapping polygon will be "subtracted" from the polygons that it

overlaps.

 

3.  Select the overlapping polygon using the Pick tool ( ).

4.  Select the Edit - Polygon Functions - Subtract Polygon command to "subtract" 

the overlapping polygon from the polygons that it overlaps.

5.  The result of "subtracting" the polygon with the Subtract Polygon command is 

shown below.  The boundaries of the red polygon labeled "A" are now coincident

with the boundaries of the adjacent polygons.

 

The boundaries of the red polygon labeled "A" are now coincident with the

boundaries of the adjacent polygons.



 

C.  Creating Holes in Polygons and Removing Holes from Polygons

 

Often it is necessary to create holes in polygons or remove holes from polygons, like the

hole shown in the green polygon labeled "PR" shown below.

 

The green polygon labeled "PR" contains a hole.

 

To add a hole to a polygon, use the following procedure.

1.  Select the Edit - Start Editing command to edit the polygon shapefile.

2.  Select the polygon to add a hole to using the Edit Points/Edit Select tool ( ). 

Note:  The polygon is selected when each of its vertices are numbered.

3.  Right mouse click on the selected polygon where you want to start adding the hole

and select the Polygon Functions - Add Part (or make hole) command, as shown 

below.  Note:  The Add Part (or make hole) command is only available on the

right mouse click popup menu and NOT on the Edit menu.

 



The Add Part (or make hole) command is used to make holes in polygons.

 

4.  Now digitize the boundary of the hole.  Note:  It's best to digitize a hole in the

clockwise direction, otherwise the polygon will have to be fixed using the

Polygon Functions - Fix Polygon Winding command.

5.  To finish digitizing the hole, double-click OR select the Edit - Close Shape

command.

6.  If the hole doesn't appear when it is digitized, make sure the polygon is still

selected and select the Polygon Functions - Fix Polygon Winding command.

 

To remove a hole from a polygon, use the following procedure.

 

1.  Select the Edit - Start Editing command to edit the polygon shapefile.

2.  Select the border of the hole to be removed using the Edit Points/Edit Select tool

( ).  Note:  The hole is selected when each of its vertices are numbered

and shown in green as shown below.

 

The hole in the green polygon labeled "PR" is selected when its vertices are

numbered and shown in green.

 

3.  Once the hole has been selected, select the Polygon Functions - Delete Part 

command to remove the hole from the polygon.

 

D.  Drilling Polygons using the Drill Polygon Command



 
When digitizing polygons into areas where polygons already exist, it is often easier to
"drill" a new polygon using the Drill Polygon command, rather than trying to snap the
new vertices to the vertices of an existing polygon.
 
Note: The Drill Polygon command only works with polygons that intersect the
borders of polygons they overlap.  To "drill" a polygon that is entirely contained
within another polygon, first create a hole in the containing polygon, then
"snap" a new polygon into the hole.
 
In the following example, the red polygon labeled "A" (shown below) will be "drilled" into
the adjacent polygons using the Drill Polygon command.
 

The red polygon labeled "A" will be drilled into the adjacent polygons using the
Drill Polygon command.

 

1.  Select the Edit - Start Editing command to edit the polygon shapefile.

2.  Using the New Shape Tool ( ), digitize a new polygon that overlaps the edges of 

the green, blue, brown, and peach polygons as shown below. 

3.  Select the new shape using the Pick tool ( ).  Note: If the new shape overlaps 

other shapes entirely (as it does in this example), then use the Layer - Select 
Last Shape command to select the new shape.



The overlapping polygon will be "drilled" into the polygons that it overlaps.
 

4.  Select the Edit - Polygon Functions - Drill Polygon command to "drill" the

overlapping polygon into the polygons that it overlaps.

5.  The result of "drilling" the polygon with the Drill Polygon command is shown below. 
The boundaries of the red polygon labeled "A" are now coincident with the
boundaries of the adjacent polygons.

 

The boundaries of the red polygon labeled "A" are now coincident with the
boundaries of the adjacent polygons.

 

E. Creating Polygons that are Within other Polygons

 
As mentioned above, the Drill Polygon command can NOT be used to create
polygons that are entirely within the boundaries of another polygon.
 
To create polygons that are entirely within other polygons, use the following procedure.
 

1.  First create a hole in the underlying polygon that is the shape of the polygon
you want to create using the procedure mentioned in C. Creating Holes in
Polygons and Removing Holes from Polygons (above), as shown below.

 



First create a hole in the underlying polygon.
 

2.  Set the Snapping layer to the editable layer using the snap layer listbox, shown
below.

 

Set the Snapping layer in the snap layer listbox.
 

3.  Then, using the New Shape Tool ( ), digitize a new polygon and "snap" its

vertices into the newly created hole as shown below.
 

The new polygon is being "snapped" into the hole.
 

(Brian Brown, 1/05)
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the Software, where an end-user can reasonably be expected to
see it.

2. The above copyright notice must appear in all copies of the
Software and in any portions thereof. The copyright notice
must be followed immediately by a notice stating that the

Software is made available under the terms of this license,
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or implied warranty.

The original source code for NADCONV has been enhanced in accordance



with those terms. The enhancements are part of SHPTRANS, and are
Copyright (c) 1999-2003 by Bruce Dodson.

In order to exercise rights in SHPTRANS, or in any other work that
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